Chapter 2. Installation

Table of Contents
SQL database requirements
Supported operating systems
Tools required for installation
Installing mnoGoSearch
Possible installation problems
Creating binary distribution
Installation registration

SQL database requirements

Note that, if you want to compile mnoGoSearch with one of the supported SQL database, you must have the database system already installed before installing mnoGoSearch.

Since version 3.2, it is possible to use mnoGoSearch with several SQL databases.

You also should have enough permissions to create a new database or to write into an already existing one.

MySQL notes: We tested mnoGoSearch with 3.22.x, 3.23.x, 4.0.x and 4.1.x MySQL versions. zlib library must be installed. On a Linux system you'll need zlib-devel RPM to successfully compile mnoGoSearch with MySQL.

PostgreSQL notes: If you want to build mnoGoSearch with PostgreSQL, 7.3.x or later release required.

SQLite notes: 2.8.x version is known to work.

iODBC notes: iodbc-2.50.22a is known to work.

unixODBC notes: unixODBC-1.7 is known to work.

Solid notes: 03.00.0043 version is known to work.

Interbase notes:

MimerSQL notes: 9.1.x version is known to work.

FreeTDS notes: 0.52 version is known to work with MS SQL 7.0.

Oracle8 notes: 8.0.5.X is known to work.

Oracle9i notes: 9.0.1 is known to work.

IBM DB2 notes: V8.1 EE is known to work.

Sybase notes: ASE 12.5 is known to work.